On 3/20/2013 5:08 PM, Abhishek Koneru wrote:
Please review the patch with fixes for ticket 536 - Catch the keyboard interrupt during the execution of pkispawn and pkidestroy.
Some comments: 1. Please add a short subject line in the comment like the other patches. 2. Any reason you use signal handler instead of try-except? 3. If we keep the signal handler, the signal.signal() invocation should be moved into the main program so it's easier to read. 4. Does it print a single blank line between the interrupted line and the 'canceled' message? See the example: https://fedorahosted.org/pki/ticket/536 5. The US spelling is 'canceled' instead of 'cancelled': http://grammarist.com/spelling/cancel/ I think in the future we'll provide a proper translation & spelling for each locale, but to be consistent for now let's use US spelling as the default. -- Endi S. Dewata